Global upstream provider outage, some services may be impacted
Resolved·Degraded performance

Cloudflare has fully resolved the upstream service disruption that was impacting PDF generation and other related services. Our systems have recovered, and all functionalities within Revalate AI Studio are now operating normally.

We will continue to monitor performance closely, but no further impact is expected at this time.

Thank you for your patience while the upstream provider completed their remediation.

Tue, Nov 18, 2025, 06:05 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

Cloudflare has fully resolved the upstream service disruption that was impacting PDF generation and other related services. Our systems have recovered, and all functionalities within Revalate AI Studio are now operating normally.

We will continue to monitor performance closely, but no further impact is expected at this time.

Thank you for your patience while the upstream provider completed their remediation.

Tue, Nov 18, 2025, 06:05 PM

Monitoring

Cloudflare, an upstream provider, is currently experiencing a major global service disruption. This incident affects multiple Cloudflare services and is causing intermittent availability to some services like generating estimate pdf's.

Cloudflare has identified the root cause and is actively implementing fixes. Some services are recovering, but elevated error rates may persist while Cloudflare continues remediation.

We are closely monitoring the situation and will restore full availability as soon as Cloudflare’s network stabilizes.

We will provide updates as the upstream provider progresses.

Thank you for your patience.

Tue, Nov 18, 2025, 03:37 PM(2 hours earlier)

Investigating

A global upstream provider is currently experiencing an outage which is impacting pdf generating services. We are actively investigating the extent of the impact.

Tue, Nov 18, 2025, 02:08 PM(1 hour earlier)